Few days ago my Debian jessie package update(e.g. apt-get upgrade) start failing with following message:

I was able to fix the problem by using solution described at https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=589238 and https://wiki.debian.org/LSBInitScripts

Long story short:
When I tried

I saw that dependency information is missing in smfpd init script. The solution was to add following:

to

after

and that was it. keep in mind that you might have to run also :

if update still fails.

Debian jessie failing update with insserv rejected the script header
Tagged on:         

4 thoughts on “Debian jessie failing update with insserv rejected the script header

Leave a Reply

Your email address will not be published. Required fields are marked *